No internet connection
  1. Home
  2. Support

Stream Deck and or Sound Flow falls asleep after about 30 seconds of no use

By dave johnson @dave_johnson
    2020-04-27 23:20:01.653Z


    Whenever I let the stream deck sit for about 30 seconds with no interaction it falls asleep.
    I can wake it up by command tabbing back and forth to pro tools (which has a trigger deck).
    Alternativly I can wake it up by clicking "edit macros and shortcuts".

    I recently upgraded my mac and I'm running on catalina now.
    I recall it falling asleep before but that was after maybe 30 minutes of no use?

    I've checked and made sure app nap is not on for stream deck or sound flow.
    In the stream deck preferences it is set to never go to sleep either.

    Possibly a catalina issue?
    Any help would be greatly appreciated.

    Thanks so much!

    Solved in post #7, click to view
    • 7 replies
    1. Hi Dave.

      Thank you for reporting this.
      The Stream Deck sleep settings are not controlled by SoundFlow.

      You control this behavior in the Preferences window of the Stream Deck app - look for "Sleep After":

      1. Ddave johnson @dave_johnson
          2020-04-28 13:47:12.316Z

          Thanks for the fast reply Chris.

          Yup that was the first thing I checked.
          It is set to never sleep.
          I'm on firmware version 1.02.004

          Very odd.

          I mainly use sound flow for the stream deck integration and a separate program for quick keys.
          I'm gonna make a few shortcuts in soundflow and see if soundflow goes to sleep as well.

          Thanks for the help,

          1. One thing to try would be to set it to sleep at a lower interval, and then again to never sleep. This may force the Stream Deck app to rewrite the setting to the device's firmware.
            But regardless, the device going to sleep (I'm assuming you mean it turning off) is not something SoundFlow controls.

            Keep in mind, in version 3.7 that we're currently beta testing, you'll get a whole new way to connect to your Stream Decks, where SoundFlow will be directly in charge of talking to the device, and the Stream Deck app no longer is used.
            This may also help with the issue you're seeing.

            1. Ddave johnson @dave_johnson
                2020-04-28 14:17:42.492Z

                I just tried swapping between 5, 30 and 2 hours and they all go to sleep after about 30 seconds regardless.
                Yes by sleep I mean it the buttons all grey out to the soundflow dimmed icons.

                I tried the quick key and it is definitely the deck going to sleep and not soundflow.

                I'm on software version 4.6.4 on streamdeck.
                I'll try uninstalling and reinstalling at the end of the day today.
                If I have time I'll boot up my old system and see if its doing the same thing there just to rule that out.

                As a work around I just made a quick key that launches the finder window then launches protools and it seems to toggle it back on.
                Should be easy enough to press every time I need to use it.

                1. Yes by sleep I mean it the buttons all grey out to the soundflow dimmed icons.

                  This is technically not the "going to sleep" that I thought you meant, this is unrelated to the Stream Deck "sleep" setting. This appears to be something different.

                  Please try following the troubleshooting guide here - especially make sure you follow the general troubleshooting rules:

                  1. Ddave johnson @dave_johnson
                      2020-04-28 14:36:40.802Z

                      Thanks Chris,

                      So I figured it out...
                      I had the stream deck running through a USB 3 hub (as I did in my previous rig with no issues at all).
                      The only other things in the hub were 2 iloks.
                      I removed the hub and went straight into the mac and the issue is gone.

                      I guess it wasn't drawing enough power?
                      Strange that it would work but for only a short period.

                      Thanks so much for all the help!
                      You guys are doing great work!

                      Thanks again,

                      1. Oh, interesting. Good to know, thank you :)